Graflex.org Forum Index Graflex.org
Get help with your Graflex questions here
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

rollfilm back repair...

 
Post new topic   Reply to topic    Graflex.org Forum Index -> Film Help
View previous topic :: View next topic  
Author Message
manifestdestiny



Joined: 30 Dec 2001
Posts: 8
Location: NYC

PostPosted: Mon Sep 09, 2002 6:45 pm    Post subject: Reply with quote

hi...i have come accross a singer-graflex 120 rollfilm back for my crown graphic. it's in nice condition and worked perfectly...until i ran a few rolls of film through it. somehow, the lever-advance mechanism has broken. the lever still moves, but no longer makes the clicking sound, and it does not engage the metal teeth that advance the roll.

it doesn't seem like a terrible problem, but i have no idea how to go about opening it up and fixing it. anybody have any pointers/ideas/tips? thanks...
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Schmell



Joined: 25 Aug 2002
Posts: 19

PostPosted: Mon Sep 09, 2002 7:14 pm    Post subject: Reply with quote

Your best bet is to take it to a local camera shop. I had something similar happen to the 120 back for my Bronica ETR. Turns out I had broken on of the pieces used to turn the cogs used to advance the film. It was an easy repair though.

If you can find someone who does MF in your area take it in and see what they say. You should be able to get an estimate easily enough. Sometimes the repairs are VERY simple. Sometimes not. If it isn't you'll have to send away. But check locally first.

Back to top
View user's profile Send private message
Dan Fromm



Joined: 14 May 2001
Posts: 1889
Location: New Jersey

PostPosted: Sun Sep 22, 2002 5:04 pm    Post subject: Reply with quote

Quote:

On 2002-09-09 11:45, manifestdestiny wrote:
hi...i have come accross a singer-graflex 120 rollfilm back for my crown graphic. it's in nice condition and worked perfectly...until i ran a few rolls of film through it. somehow, the lever-advance mechanism has broken. the lever still moves, but no longer makes the clicking sound, and it does not engage the metal teeth that advance the roll.

it doesn't seem like a terrible problem, but i have no idea how to go about opening it up and fixing it. anybody have any pointers/ideas/tips? thanks...
Since you're in NYC, try armatos. Sorry for the lack of capital letters, broken keyboard.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Graflex.org Forum Index -> Film Help All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group